[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: FTPAPIR4 FTP Error 15 (Unable to create socket)

Hi Christine,

That's strange -- I haven't run into that problem before. Could it be that you are running out of descriptors? Maybe you're forgetting to call FTP_quit() in some cases (like, if there's an error?) and therefore it's never cleaning up the descriptors, so you eventually run out?


On 5/9/2015 12:31 PM, Christine Krebs wrote:
    We are receiving an 'Unable to create socket' error from the FTPAPIR4
    service program. The error is happening in the TCP_CONN routine when
    the 'socket' C program is called.�  The call initiating the connect is
    FTP_LIST procedure within FTPAPIR4.�  Has anyone received this error
    message before?�  Please read below for the background of our process.
    Any help would be appreciated.
    We have a job that is set up to continuously run that connects every
    minute to a remote FTP server to put and get data.�  Here is the flow
    of the program.
    1. builds a group of work files in the IFS.
    2. connects to the remote server (FTP_OPEN)
    3. logs into the server (FTP_LOGIN)�
    4. sets passive mode on (FTP_PassiveMode)
    5. changes directories (FTP_chDir)
    6. puts the files on the server (FTP_Put)
    7. gets a list of files to import � (FTP_LIST)
    8. change directories (FTP_chDir)
    9. gets the files from the server and moves them into the IFS (FTP_Get)
    10. disconnects from server (FTP_Quit)
    11. processes the files from the IFS into our database
    12. program sleeps for 60 seconds
    13.. repeats the process
    This process will run successfully for 2 hours sometimes but typically
    the job has been ending every 10-15 minutes. We will get and put data
    for that time period. �
    The initial error message, 'Unable to create socket', occurs during the
    FTP_LIST call.�  The program will loop back around and try to reconnect
    and get the same error.�  We can not successfully reconnect until the
    job ends and we restart it.�  We have tried both active and passive
    mode.�  The program is compiled with *NEW as the activation group.�  It
    was originally *CALLER.�  The error is always during the FTP_List
    procedure call.
    Also the trace logs running on our ISeries and the remote server do not
    show any activity when we get this error trying to run the FTP_List
    procedure and any subsequent attempts to connect until the job is
    Christine Krebs

    This email and any files transmitted with it are confidential and
    intended solely for the use of the individual or company to whom they
    are addressed. Do not disclose, distribute, or copy this email to
    others outside your company. If you have received this email in error,
    please notify the sender immediately and delete this email from your

This is the FTPAPI mailing list.  To unsubscribe, please go to:

This is the FTPAPI mailing list.  To unsubscribe, please go to: