[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: STOR (put) Command Receiving Error - RESOLVED


I found an errant change of directory in the FTP program that was sending me to a folder that we must not have had permissions to and thus the PUT was failing with that odd error message.

Strange though since I would have expected to not be able to change to the directory at all, but apparently I could, but just could not do anything upon arriving there.

Sorry for the bother but thanks a ton for your support and help!

On 10/19/2012 6:29 PM, Scott Klement wrote:
Hi Brian,

Here is the command that you say the IBM client is sending (copy/paste
from your message), under the covers:


and here's what FTPAPI is sending (also a copy/paste from your message):


They look the same to me?!    I also checked and discovered you are
using "active mode" FTP in both cases.  So that's not a problem
either.   These are the only differences I see:

1) from the IBM cient, you are using ASCII mode, but from FTPAPI you are
using BINARY mode.  Consider changing FTPAPI to ASCII mode, maybe that
will help.

2) You are using a different port number for FTPAPI vs. the IBM
client.   This is normal and expected behavior, the port number is
assigned dynamically by the OS based on which ports are available. But I
guess it's possible that FTPAPI might happen to be hitting the wrong ports?

FTPAPI has PORT 172,25,10,10,56,15
This decodes to IP address, port number 14351.
IBM has PORT 172,25,10,10,64,131,
which decodes to the same IP address, but port number 16515

Again, this is completely normal...  each time you do it, you should get
a different port number, that's just the way FTP works.  But, if by some
dumb luck you happen to accidentally hit a port that's firewalled off,
you could potentially get the error you cite.  This is unlikely, but

So, I'm baffled as to what the difference could be?   I'm assuming you
are signing in with the exact same user name and password?


On 10/19/2012 3:15 PM, Brian wrote:
Hi Scott,

I do recall you asking for that and then I tried an command line FTP a
little later and received an error so I pushed to the people on the
server end trying to see if they had some permissions issues and so
on, but no luck there.

I then went back to try it again today from a command line and it
worked so I got back to troubleshooting and forgot about the debug.

So, here is the debug info.  It looks like what I see in the FTPAPI
log so I am still confused but maybe you will see something I do not.

Thanks again.

>>> PORT 172,25,10,10,64,131
200 PORT command successful.
150 Opening ASCII mode data connection for PGP ARP INBNDR GAFRARP.
226- Transfer complete - acknowledgment message is pending.
226- Transfer complete - acknowledgment message is pending.
226 Transfer complete (Batch Number = 26995).
   965 bytes transferred in 0.005 seconds. Transfer rate 197.632 KB/sec.

On 10/19/2012 3:24 PM, Scott Klement wrote:
Hi Brian,

In order to make sense what's happening here, I need to see the actual
STOR command that's being sent from the FTP client to the FTP server. In
order to see that information, you need to run the FTP DEBUG command
prior to running your put.

In IBM's client, you do this:

    FTP RMTSYS(the-system)
   -- sign in as normal --
   Type:  DEBUG 1

Now do your put command.  It should show what the STOR command and it's
responses look like on your screen.  If FTPAPI sends the exact same STOR
command, then it should work.  Take a look at that, along with any other
commands sent after you type PUT, and post them here.

I mentioed this in a previous e-mail to you as well, but you didn't try
the DEBUG subcommand... makes me wonder if maybe I was too terse.  Hope
this explanation helps you see what I'm looking for.


On 10/19/2012 1:42 PM, Brian wrote:

I was able to perform the following from a command line FTP session to
place the file on to the remote server successfully.

I am thinking there is something special going on with respect to the
double quotes they instructed me to put around the file, but I am not
200 PORT command successful.
150 Opening ASCII mode data connection for PGP ARP INBNDR GAFRARP.
226- Transfer complete - acknowledgment message is pending.
226- Transfer complete - acknowledgment message is pending.
226 Transfer complete (Batch Number = 158785).
   965 bytes transferred in 0.007 seconds. Transfer rate 141.166

On 10/11/2012 8:42 PM, Scott Klement wrote:
I don't see anything wrong, here... Maybe you're not allowed to do
active FTP, and you need to do passive?  It's worth a try.

If that doesn't help, try doing it the way that works (from the IBM
client) but use the 'debug' subcommand to enable the same sort of log
output.  Post that, and we'll see what's different between them.

On 10/11/2012 4:54 PM, Brian wrote:
With logging on, it looks like this in the job log:

1: > PASS **********
1: 230 Connect:Enterprise UNIX login ok, access restrictions apply.
1: > CWD /
1: 250 CWD to '/' successful
1: > TYPE I
1: 200 Type set to I.
1: > PORT 172,25,10,10,56,15
1: 200 PORT command successful.
1: 550 You are not allowed to issue this command

This is the FTPAPI mailing list.  To unsubscribe, please go to: