[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: No SOAP input for WS!

   Here is the code.
   D SOAP            s          32767A   varying
   D rc              s             10I 0
   D Result          s             12P 2
   D dateDs          ds
   D   EarliestDeliveryDate...
   D                               15a
   D   LatestDeliveryDate...
   D                               15a
   SOAP =
   '<?xml version="1.0" encoding="iso-8859-1" standalone="no"?>
   +'    xmlns:SOAP="[1]http://schemas.xmlsoap.org/soap/envelope/";
   +'    xmlns:tns="[2]http://tempuri.org/";>'
   +'   <tns:CalculateTransitDates>'
   +'   <tns:ServiceDS>'
   +'   <tns:ServiceParam>'
   +'     <tns:OrderNumber>0454545401</tns:OrderNumber>'
   +'     <tns:Inquiry>Y</tns:Inquiry>'
   +'     <tns:TransitDateDriver>D</tns:TransitDateDriver>'
   +'     <tns:ShipDateDriverType>A</tns:ShipDateDriverType>'
   +'     <tns:AnchorFromDateTime>2009-05-08T00:00:00-05:00'
   +'     </tns:AnchorFromDateTime>'
   +'     <tns:AnchorThruDateTime>2009-05-09T00:00:00-05:00'
   +'     </tns:AnchorThruDateTime>'
   +'     <tns:OriginLocationID>141541</tns:OriginLocationID>'
    +'     <tns:CurrentReshipLocationID
    +'     <tns:AlternateReship2
    +'     <tns:AlternateReship3
    +'     <tns:AlternateReship4
    +'     <tns:AlternateReship5
    +'     <tns:AlternateReship6
    +'     <tns:AlternateReship7
    +'     <tns:AlternateReship8
    +'     <tns:AlternateReship9
    +'     <tns:AlternateReship10
    +'     <tns:User>USER1</tns:User>'



    +'  </tns:CalculateTransitDates>'


    rc = http_url_post_xml(
                      : %addr(SOAP) + 2
                      : %len(SOAP)
                      : *NULL
                      : %paddr(Incoming)
                      : %addr(dateDs)
                      : HTTP_TIMEOUT
                      : HTTP_USERAGENT
                      : 'text/xml'
                      : '[4]http://tempuri.org/CalculateTransitDates');
       *In LR = *On;
   I was trying to copy the debug log from tmp but it was not allowing
   me, i deleted it, renamed the folder to see if it will allow me to
   copy(was getting "in use" error). Now even if i created the folder tmp
   back its not creating the logs anymore. Please help.

   On Wed, Aug 26, 2009 at 1:36 AM, Scott Klement
   <[5]sk@xxxxxxxxxxxxxxxx> wrote:

     I think we'll need two things from you:
     1) If possible, create the smallest/simplest possible program that
     reproduces the problem.  One that I can easily copy/paste to my
     compile, and run.  (A program that I can't compile or run is of
     2) Also, please create a debug log, and post it.  (Scrub any
     "authorization" or "proxy-authorization" values in the log -- and
     other confidential information.)  More details on the 2nd-half of
     following page:

   Mohamed Musthafa Safarulla wrote:
   >    I was trying to call a webservice. But for some reason the WS was
   >    returning the error that input SOAP string is invalid in the
   error. I
   >    made a local copy of the WS in my machine and tried to debug the
   WS. I
   >    found that i am not getting any SOAP string as input. When i
   tried all
   >    the other WSs it worked but couldnt find the issue with this
   >    particular code.
   >    Any idea why this is happening. Please help.

     This is the FTPAPI mailing list.  To unsubscribe, please go to:



   1. http://schemas.xmlsoap.org/soap/envelope/
   2. http://tempuri.org/
   3. http://xx.xx.xx.xxx/SxxService/SxxService.asmx
   4. http://tempuri.org/CalculateTransitDates'
   5. mailto:sk@xxxxxxxxxxxxxxxx
   6. http://www.scottklement.com/httpapi/beta/
   7. http://www.scottklement.com/mailman/listinfo/ftpapi
This is the FTPAPI mailing list.  To unsubscribe, please go to: